İnternet, bilgi, bilişim güvenliğine dair her türlü karalamalara sahiplik yapan kişisel bir blog.

Excel’de formüller

Merhaba arkadaşlar. Bu konumun önlisans “Bilgisayar Programcılığı” okuyan arkadaşlarımızın yararlanacağı vize öncesi bir kaynak olabilir düşüncesiydim. Vizelerde tahminim olarak; EĞER, VE, YADA formülleri üzerine sorular gelecektir. Bir tablo verilerek öğrencilerin kalma ve geçme durumlarının hesaplatılması olabilir mesela. Matematiksel işlemler basit görünse de bazen eğer, ve, yada formülleri kafa karıştırıcı olabiliyor. Ondokuz Mayıs Üniversitesi geçme sisteminde final notunun 50’den az olması durumunda öğrencinin o dersden kalması nedeniyle final notununda geçme durumuna dahil edilmesi gerekmektedir. Bu üniversiteden üniversiteye değişen bir durumdur. Zaten vizelerde de xxx üniversite sınav geçme sistemine göre denilir.

Hemen başlayalım. Yapmak istediğim E2, E3, E4, E5 hücrelerine her öğrenciye ait başarı ortalamasını, F2, F3, F4, F5 hücrelerine ise Geçme veya Kalma durumlarını yazdırmak istiyorum.

Fx çubuğuna yazacak olduğum formüller şunlardır.

Başarı ortalaması hesaplamak için; E2, E3, E4, E5 hücrelerine girilecek.
// VİZENİN %40’ını, FİNAL’in %60’ını alıp topluyorum.

  • =(C2*40/100+D2*60/100) 
  • =(C3*40/100+D3*60/100)
  • =(C4*40/100+D4*60/100)
  • =(C5*40/100+D5*60/100)

Durum hesaplamak için; F2, F3, F5, F5 hücrelerine girilecek.
// FİNAL 50’den yüksek VE Ortalaması 60’dan yüksek ise Geçti değilse Kaldı yaz

  • =EĞER(VE(D2>=50;E2>=60);”GEÇTİ”;”KALDI”)
  • =EĞER(VE(D3>=50;E3>=60);”GEÇTİ”;”KALDI”)
  • =EĞER(VE(D4>=50;E4>=60);”GEÇTİ”;”KALDI”)
  • =EĞER(VE(D5>=50;E5>=60);”GEÇTİ”;”KALDI”)


Sonuç aşağıda gibi çıkmalıdır.

Mustafa

2004 yılından bu yana Web ve Bilgi Güvenliği üzerine araştırmalarda bulundum. Çok sayıda yerli yada yabancı websitelerinde bulunan zaafiyetleri ilgililere göndererek kapatılmasını sağladım. Octosec ailesindenim. Siber Güvenlik Eylem Planı kapsamında TSE Kayıtlı Sızma Uzmanı sertifikam bulunmaktadır.

1 Comment

  1. ya rıca etsem vize final notonu hesaplama formulunu yazarmısınız cok acıl

Leave a Reply